How to draw graphical shapes

graphical shapes are used to draw links between individual components of electric wiring diagrams, such as mechanical links between individual components, border lines around individual functional units, etc.

Individual graphical shapes to be drawn may be selected from the Draw menu or by pressing the corresponding soft button on the toolbar.

   Line

First select the line graphic object from the Draw menu. Then click the left mouse button at the starting point of your line, drag the mouse to the end point of your line and press the left mouse button. You can now start drawing another line or select a new graphic object from the menu.

   Polyline

First select the polyline graphic object from the Draw menu. Then click the left mouse button at the starting point of your line, drag the mouse to the next point of your line, press the left mouse button, drag the mouse to the next point, etc. After you have completed drawing the polyline, press the Esc key.

   Curve

Use this function to draw one or several linked Bezier curves. The curves are automatically linked together to get a smooth link.

First select the curve graphic object from the Draw menu. Then click the left mouse button at the starting point of your curve, drag the mouse to the next point of your curve, press the left mouse button, drag the mouse to the next point of the curve, etc. After you have completed drawing the curve, press the Esc key.

The Bezier curve shape is defined by 4 points: two end points and two control points. The ends of the curve are defined by the two end points. The curve shape also depends on the control points, which act like magnets. Based on the distance of the control points from the end points the shape of the curve is defined. Therefore the curve may take many different shapes.

   Rectangle

First select the rectangle graphic object from the Draw menu. Then click the left mouse button at the rectangle left upper corner, drag the mouse to the right bottom point of your rectangle and press the left mouse button. You can now start drawing another rectangle or select a new graphic object from the menu.

   Rounded rectangle

The procedure is similar to drawing a rectangle except a third point, which is used here to define rectangle rounding.

   Arc, chord and pie

Proceed in the same way as when drawing a rectangle but you will also need to set up the starting and end angles of the arc. Enter the values of the angles in the Properties panel in tenths of degree.

 

   Ellipse

The procedure is similar to rectangle drawing but the inscribed ellipse is drawn instead of the rectangle.

   Polygon

Draws a polygon.

First select the polygon graphic object from the Draw menu. Then click the left mouse button at the starting point of your polygon, drag the mouse to the next point of your polygon, press the left mouse button, drag the mouse to the next point, etc. After you have completed drawing the polygon, press the Esc key.

   Outlet

Outlet can be inserted only in symbols editor (documents with extension ".ppd"). It is defined by one point. It is displayed in red color to be easily visible and it is larger when it is selected.

How to draw arrows

Draw a line, Bezier curve or an arc and select type of the arrow in the Properties panel.

The direction of the arrow can be changed by clicking on the link flip arrow in the bottom part of the Properties panel.

Orthogonal drawing mode

Orthogonal drawing mode is activated by pressing Ctrl key when drawing objects. Lines are drawn vertically, horizontally or with angle 45°. Rectangles and ellipses are drawn as squares and circles in this mode.

Ability to add or remove points of a line or a polygon

This function allows adding to or removing points of a line or a polygon.

ubrat bodpřidat bod

Procedure:

  • Select line or polygon.
  • Select menu command Draw – Add or delete
  • By clicking on line edge add a point (A)
  • By clicking on line node delete a point (B)
  • Press Esc to return to Selection mode

Smooth modification of Bezier curve control points

modification of Bezier curve control points

If the Ctrl key is pressed when a Bezier control point is moved, the program moves the opposite control point so as to make the curve smooth.